HowTo: RaspberryPi – „SSH reagiert nicht“ oder „ist sehr langsam“-Problem beheben

Neulich hatte ich nach der Neuinstallation von Raspian auf dem RaspberryPi das Problem, dass der Zugriff über SSH quälend langsam war. Meistens könnte man den Benutzernamen und das Passwort noch „normal-schnell“ eingeben, aber dann dauerte es oft bis zu zehn Minuten bis die gewohnte Willkommens-Nachricht angezeigt wurde.

Um dieses Problem zu lösen hat mir folgende Lösungsmöglichkeit geholfen.


Sicherheitshinweise

Ich weiß die folgenden Hinweise sind immer irgendwie lästig und wirken unnötig. Aber leider haben schon viele Menschen die es "besser" wussten aus Leichtsinnigkeit Augen, Finger oder anderes verloren bzw. sich verletzt. Im Vergleich dazu ist ein Datenverlust fast nicht der Rede Wert, aber auch diese können echt ärgerlich sein. Deswegen nehmt Euch bitte fünf Minuten Zeit um die Sicherheitshinweise zu lesen. Denn auch das coolste Projekt ist keine Verletzung oder anderen Ärger wert.
https://www.nerdiy.de/sicherheitshinweise/


Übersicht

Bevor ihr mit diesem Artikel startet solltet ihr den RaspberryPi soweit vorbereitet haben, dass dieser über das Netzwerk erreichbar und per SSH Steuerbar ist.

Die folgenden drei Artikel beschreiben was zu tun ist um den RaspberryPi soweit vorzubereiten:
RaspberryPi – Einrichten für Nerdiys!
RaspberryPi – Die Erste Konfiguration!
RaspberryPi – Den RaspberryPi über SSH steuern

Benötigtes Werkzeug:
-keins-

Benötigtes Material:

In der folgenden Liste findet Ihr alle Teile die Ihr zur Umsetzung dieses Artikels benötigt.


Per SSH auf dem RaspberryPi einloggen

Um zu beginnen müsst Ihr Euch als erstes mit Putty per SSH auf dem RasPi einloggen. Wie das geht ist im Artikel RaspberryPi - Den RaspberryPi über SSH steuern beschrieben.

Nach der Eingabe Eures Benutzernamen und Passworts könnt Ihr die ersten Befehle eingeben.

IPQoS Wert ändern

Diese Änderung behebt den Fehler, dass die SSH-Verbindung zu eurem RaspberryPi nach der Eingabe von Benutzername und Passwort so langsam wird, dass die Bedienung über die Konsole nicht mehr möglich ist.
Dieser Fehler tritt nur auf, wenn Ihr über ein Funknetzwerk auf den RaspberryPi zugreift. Bei einer Kabelverbindung sollte er nicht auftreten.

Um ihn zu beheben müsst ihr einen Befehl bzw. Wertänderung in zwei Konfigurationsdateien eures SSH-Clienten eintragen.

Öffnet dazu die erste Konfigruationsdatei mit dem Befehl:

sudo nano /etc/ssh/ssh_config
Navigiert mit den Pfeiltasten bis zum Ende der Datei…
… und fügt dort die Wertänderung „IPQoS 0x00“ ein. Speichert und schließt die Datei mit „STRG+X“ und „Y“ zum Bestätigen.
IPQoS 0x00

Das gleiche wiederholt Ihr nun nochmal mit der anderen Konfigurationsdatei. Öffnet sie dazu mit:

sudo nano /etc/ssh/sshd_config
Navigiert mit den Pfeiltasten bis zum Ende der Datei…

… und fügt dort die Wertänderung „IPQoS 0x00“ ein. Speichert und schließt die Datei mit „STRG+X“ und „Y“ zum Bestätigen. Nach einem Neustart des RaspberryPi’s(Befehl „sudo reboot“) sollte Eure Konsolen-Verbindung nun wieder so schnell wie gewohnt sein.


Wert ändern mit einem Befehl

„Kveldulfur“ hat in den Kommentaren den Hinweis hinterlassen, dass man manchmal gar nicht die Möglichkeit hat bis zur Einstellung des Wertes zu navigieren. In diesem Fall lässt sich der Wert auch mithilfe nur eines Befehls korrekt einstellen. Gebt dazu einfach den folgenden Befehl ein.

echo „IPQoS 0X00“ >> /etc/ssh/ssh_config && echo „IPQoS 0X00“ >> /etc/ssh/sshd_config

Startet danach Euren RaspberryPi neu und die Konsole sollte nun schneller reagieren.


Ich hoffe bei euch hat alles wie beschrieben funktioniert. Falls nicht oder ihr Fragen oder Anregungen habt lasst es mich in den Kommentaren bitte wissen. Ich trage dies dann ggf. in den Artikel nach.
Auch Ideen für neue Projekte sind immer gerne willkommen. 🙂

Fab

P.S. Viele dieser Projekte - besonders die Hardwareprojekte - kosten viel Zeit und Geld. Natürlich mache ich das weil ich Spaß daran habe, aber wenn Du es cool findest, dass ich die Infos dazu mit Euch teile, würde ich mich über eine kleine Spende an die Kaffeekasse freuen. 🙂

Buy Me a Coffee at ko-fi.com

2 Kommentare

  1. Hallo!
    Da ich leider nur per WLAN mit auf den RasPI Zero einloggen konnte, war es unmöglich einen Editor dort zu öffnen, um die Werte in der Konfiguration nachzutragen. Ich habe folgende Befehle genutzt:

    echo „IPQoS 0X00“ >> /etc/ssh/ssh_config
    echo „IPQoS 0X00“ >> /etc/ssh/sshd_config

    Und anschließend Strom ab und wieder ran und es lief wieder besser.

Kommentar hinterlassen

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.